import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"(?:https?:(?:\\?\/\\?\/|www\.)|www\.)[^\s<>"']*\.mp3"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<div class="wp-playlist wp-audio-playlist wp-playlist-light">
<div class="wp-playlist-current-item"></div>
<p> <audio controls="controls" preload="none" width="
1118 "
>
</audio></p>
<div class="wp-playlist-next"></div>
<div class="wp-playlist-prev">
</div>
<p> <noscript></p>
<ol>
<li>
<a href='https://www.caferilik.com/wp-content/uploads/2020/11/Anne-Baba-Biz-Suçluyuz-Muhafazakar-Ailelerde-Kuşak-Çatışması-Sesli-Kitap-www.caferilik.com_.mp3'>
Anne Baba Biz Suçluyuz - Muhafazakar Ailelerde Kuşak Çatışması (Sesli Kitap) www.caferilik.com<
/a></li>
</ol>
<p> </noscript><br />
<script type="application/json" class="wp-playlist-script">
{"type":"audio","tracklist":true,"tracknumbers":true,"images":true,"artists":true,
"tracks":[{"src":"https:\/\/www.caferilik.com\/wp-content\/uploads\/2020\/11\/Anne-Baba-Biz-Su\u00e7luyuz-Muhafazakar-Ailelerde-Ku\u015fak-\u00c7at\u0131\u015fmas\u0131-Sesli-Kitap-www.caferilik.com_.mp3",
"type":"audio\/mpeg","title":"Anne Baba Biz Su\u00e7luyuz - Muhafazakar Ailelerde Ku\u015fak \u00c7at\u0131\u015fmas\u0131 (Sesli Kitap) www.caferilik.com","caption":"",
"description":"\"Anne Baba Biz Su\u00e7luyuz - Muhafazakar Ailelerde Ku\u015fak \u00c7at\u0131\u015fmas\u0131 (Sesli Kitap) www.caferilik.com\".","meta":{"length_formatted":"2:28:02"},
"image":{"src":"https:\/\/www.caferilik.com\/wp-includes\/images\/media\/audio.png","width":48,"height":64},"thumb":
{"src":"https:\/\/www.caferilik.com\/wp-includes\/images\/media\/audio.png","width":48,"height":64}}]}</script>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)