const regex = /(?:https?:(?:\\?\/\\?\/|www\.)|www\.)[^\s<>"']*\.mp3/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:https?:(?:\\\\?\\\/\\\\?\\\/|www\\.)|www\\.)[^\\s<>"\']*\\.mp3', 'gmu')
const str = `<div class="wp-playlist wp-audio-playlist wp-playlist-light">
<div class="wp-playlist-current-item"></div>
<p> <audio controls="controls" preload="none" width="
1118 "
>
</audio></p>
<div class="wp-playlist-next"></div>
<div class="wp-playlist-prev">
</div>
<p> <noscript></p>
<ol>
<li>
<a href='https://www.caferilik.com/wp-content/uploads/2020/11/Anne-Baba-Biz-Suçluyuz-Muhafazakar-Ailelerde-Kuşak-Çatışması-Sesli-Kitap-www.caferilik.com_.mp3'>
Anne Baba Biz Suçluyuz - Muhafazakar Ailelerde Kuşak Çatışması (Sesli Kitap) www.caferilik.com<
/a></li>
</ol>
<p> </noscript><br />
<script type="application/json" class="wp-playlist-script">
{"type":"audio","tracklist":true,"tracknumbers":true,"images":true,"artists":true,
"tracks":[{"src":"https:\\/\\/www.caferilik.com\\/wp-content\\/uploads\\/2020\\/11\\/Anne-Baba-Biz-Su\\u00e7luyuz-Muhafazakar-Ailelerde-Ku\\u015fak-\\u00c7at\\u0131\\u015fmas\\u0131-Sesli-Kitap-www.caferilik.com_.mp3",
"type":"audio\\/mpeg","title":"Anne Baba Biz Su\\u00e7luyuz - Muhafazakar Ailelerde Ku\\u015fak \\u00c7at\\u0131\\u015fmas\\u0131 (Sesli Kitap) www.caferilik.com","caption":"",
"description":"\\"Anne Baba Biz Su\\u00e7luyuz - Muhafazakar Ailelerde Ku\\u015fak \\u00c7at\\u0131\\u015fmas\\u0131 (Sesli Kitap) www.caferilik.com\\".","meta":{"length_formatted":"2:28:02"},
"image":{"src":"https:\\/\\/www.caferilik.com\\/wp-includes\\/images\\/media\\/audio.png","width":48,"height":64},"thumb":
{"src":"https:\\/\\/www.caferilik.com\\/wp-includes\\/images\\/media\\/audio.png","width":48,"height":64}}]}</script>
</div>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}