package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^ *\S+ *$)|(^ *(\S+ ){1,3}\S+ *$)|(^ *(\S+ ){5,}\S+ *$)|(^ +(\S+ ){4}\S+ +$)`)
var str = `fsfdaf
ax x dx x xa
x x
x
x x x x
x x x
x x x x x x
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}