import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^ *\\S+ *$)|(^ *(\\S+ ){1,3}\\S+ *$)|(^ *(\\S+ ){5,}\\S+ *$)|(^ +(\\S+ ){4}\\S+ +$)";
final String string = "fsfdaf \n"
+ "ax x dx x xa \n"
+ "x x\n"
+ "x\n"
+ "x x x x\n"
+ "x x x\n"
+ "x x x x x x\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}