using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"From\s+\d{19}@";
string input = @"From 1489304828131889971@xxx Sat Jan 03 07:02:43 2015
From 1489220782115942636@82hs Fri Jan 02 08:46:51 2015";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}