import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "From\\s+\\d{19}@";
final String string = "From 1489304828131889971@xxx Sat Jan 03 07:02:43 2015\n"
+ "From 1489220782115942636@82hs Fri Jan 02 08:46:51 2015";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}