re = /From\s+\d{19}@/
str = 'From 1489304828131889971@xxx Sat Jan 03 07:02:43 2015
From 1489220782115942636@82hs Fri Jan 02 08:46:51 2015'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end