package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"totalPages":([0-9]*),`)
var str = `"totalPages":15,"bloodhoundHtml"`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}