$re = '/"totalPages":([0-9]*),/';
$str = '"totalPages":15,"bloodhoundHtml"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);