const regex = /^(10\.(?!(39|139|239))\d{1,3}\.\d{1,3}\.\d{1,3}\/\d+$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(10\\.(?!(39|139|239))\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\\/\\d+$)', 'gm')
const str = `10.154.0.4/32
10.154.0.5/32
10.239.0.4/32
10.239.0.5/32
10.39.0.5/32
10.139.0.10/32
10.110.0.5/32
10.138.0.5/32
10.169.0.5/32
10.159.0.4/32
10.1.0.5/32
10.10.0.5/32
10.99.0.5/32
10.100.0.18/32
10.102.0.18/32
10.103.0.18/32
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}