import re
regex = re.compile(r"^(10\.(?!(39|139|239))\d{1,3}\.\d{1,3}\.\d{1,3}\/\d+$)", flags=re.MULTILINE)
test_str = ("10.154.0.4/32\n"
"10.154.0.5/32\n"
"10.239.0.4/32\n"
"10.239.0.5/32\n"
"10.39.0.5/32\n"
"10.139.0.10/32\n"
"10.110.0.5/32\n"
"10.138.0.5/32\n"
"10.169.0.5/32\n"
"10.159.0.4/32\n"
"10.1.0.5/32\n"
"10.10.0.5/32\n"
"10.99.0.5/32\n"
"10.100.0.18/32\n"
"10.102.0.18/32\n"
"10.103.0.18/32\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")