$re = '/^(10\.(?!(39|139|239))\d{1,3}\.\d{1,3}\.\d{1,3}\/\d+$)/m';
$str = '10.154.0.4/32
10.154.0.5/32
10.239.0.4/32
10.239.0.5/32
10.39.0.5/32
10.139.0.10/32
10.110.0.5/32
10.138.0.5/32
10.169.0.5/32
10.159.0.4/32
10.1.0.5/32
10.10.0.5/32
10.99.0.5/32
10.100.0.18/32
10.102.0.18/32
10.103.0.18/32
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);