package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z]?pattern[A-Z]?$`)
var str = `XXpatternYY
XpatternY
This is a test XpatternY test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}