$re = '/^[A-Z]?pattern[A-Z]?$/m';
$str = 'XXpatternYY
XpatternY
This is a test XpatternY test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);