re = /^[A-Z]?pattern[A-Z]?$/m
str = 'XXpatternYY
XpatternY
This is a test XpatternY test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end