#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=#include ).*\/([^>]+)>"
Local $sString = "#include <a0/b/c/d/HeaderFile1.hpp>" & @CRLF & _
"#include <a1/b/c/d/HeaderFile2.hpp>" & @CRLF & _
"#include <a2/b/c/d/HeaderFile3.hpp>" & @CRLF & _
"#include <a3/b/c/d/HeaderFile4.hpp>" & @CRLF & _
"#include <a4/b/c/d/HeaderFile5.hpp>" & @CRLF & _
"#include <a5/b/c/d/HeaderFile6.hpp>"
Local $sSubst = ""$1""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)