re = /(?<=#include ).*\/([^>]+)>/m
str = '#include <a0/b/c/d/HeaderFile1.hpp>
#include <a1/b/c/d/HeaderFile2.hpp>
#include <a2/b/c/d/HeaderFile3.hpp>
#include <a3/b/c/d/HeaderFile4.hpp>
#include <a4/b/c/d/HeaderFile5.hpp>
#include <a5/b/c/d/HeaderFile6.hpp>'
subst = '"$1"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result