use strict;
my $str = '#include <a0/b/c/d/HeaderFile1.hpp>
#include <a1/b/c/d/HeaderFile2.hpp>
#include <a2/b/c/d/HeaderFile3.hpp>
#include <a3/b/c/d/HeaderFile4.hpp>
#include <a4/b/c/d/HeaderFile5.hpp>
#include <a5/b/c/d/HeaderFile6.hpp>';
my $regex = qr/(?<=#include ).*\/([^>]+)>/mp;
my $subst = '"$1"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";