using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @">([^\s]*)\s(.*)$";
string input = @"\>D50541 Abiotrophia defectiva Aerococcacea
\>AB303221 Acanthopleuribacter pedis Acanthopleuribacteraceae
\>AJ812213 Acaricomes phytoseiuli Micrococcaceae";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}