$re = '/>([^\s]*)\s(.*)$/m';
$str = '\\>D50541 Abiotrophia defectiva Aerococcacea
\\>AB303221 Acanthopleuribacter pedis Acanthopleuribacteraceae
\\>AJ812213 Acaricomes phytoseiuli Micrococcaceae';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);