package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)>([^\s]*)\s(.*)$`)
var str = `\>D50541 Abiotrophia defectiva Aerococcacea
\>AB303221 Acanthopleuribacter pedis Acanthopleuribacteraceae
\>AJ812213 Acaricomes phytoseiuli Micrococcaceae`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}