using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*(\<a.*?\>)).*$";
string input = @"<a href=""#"">Don't Match Me <span>web</span></a>
<a href=""#"">Don't Match Me</a>
Match Me
<span>Match Me</span>
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline | RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}