re = /^(?!.*(\<a.*?\>)).*$/im
str = '<a href="#">Don\'t Match Me <span>web</span></a>
<a href="#">Don\'t Match Me</a>
Match Me
<span>Match Me</span>
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end