$re = '/^(?!.*(\<a.*?\>)).*$/ism';
$str = '<a href="#">Don\'t Match Me <span>web</span></a>
<a href="#">Don\'t Match Me</a>
Match Me
<span>Match Me</span>
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);