#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^hsla?\(\s*(?<h>[-+]?\d{1,3}(?:\.\d+)?)(deg|grad|rad|turn)?\s*(?:,\s*|\s+)\s*(?<s>[-+]?\d{1,3}(?:\.\d+)?)%\s*(?:,\s*|\s+)\s*(?<l>[-+]?\d{1,3}(?:\.\d+)?)%\s*(?:,\s*|\s+)?(?:\s*\/?\s*(?<alpha>[-+]?[\d.]+%?)\s*)?\)$"
Local $sString = "" & @CRLF & _
"hsl(.9, .99%, .999%, .9999)" & @CRLF & _
"hsl(0240, 0100%, 0050%, 01) " & @CRLF & _
"hsl(2400, 1000%, 1000%, 10)" & @CRLF & _
"hsl(-2400.01deg, -1000.5%, -1000.05%, -100)" & @CRLF & _
"hsl(2.40e+2, 1.00e+2%, 5.00e+1%, 1E-3)" & @CRLF & _
"" & @CRLF & _
"hsl(-240, -100%, -50%, -0.1)" & @CRLF & _
"hsl(+240, +100%, +50%, +0.1)" & @CRLF & _
"HSL(240Deg, 100%, 50%)" & @CRLF & _
"hsl(240, 100%, 50%, 10%)" & @CRLF & _
"hsl(150deg 30% 60%)" & @CRLF & _
"hsl(0.3turn 60% 45% .7)" & @CRLF & _
"hsl(0.3grad 60% 45% / .7)" & @CRLF & _
"hsl(0.3rad 60% 45% / .7)" & @CRLF & _
"hsl(12 60% 45% / .7)" & @CRLF & _
"hsl(120, 100%, 50%)" & @CRLF & _
"hsl(0, 0%, 0%)" & @CRLF & _
"hsl(60, 50%, 75%)" & @CRLF & _
"hsl(270, 80%, 60%)" & @CRLF & _
"hsl(200, 20%, 40%)" & @CRLF & _
"hsl(340, 90%, 80%)" & @CRLF & _
"hsla(120, 100%, 50%, 0.5)" & @CRLF & _
"hsla(0, 0%, 0%, 0.2)" & @CRLF & _
"hsla(60, 50%, 75%, 0.8)" & @CRLF & _
"hsla(270, 80%, 60%, 0.4)" & @CRLF & _
"hsla(200, 20%, 40%, 0.6)" & @CRLF & _
"hsla(340, 90%, 80%, 0.1)" & @CRLF & _
"hsl(120 100% 50%)" & @CRLF & _
"hsl(0 0% 0%)" & @CRLF & _
"hsl(60 50% 75%)" & @CRLF & _
"hsl(270 80% 60%)" & @CRLF & _
"hsl(200 20% 40%)" & @CRLF & _
"hsl(340 90% 80%)" & @CRLF & _
"hsla(120 100% 50% / 0.5)" & @CRLF & _
"hsla(0 0% 0% / 0.2)" & @CRLF & _
"hsla(60 50% 75% / 0.8)" & @CRLF & _
"hsla(270 80% 60% / 0.4)" & @CRLF & _
"hsla(200 20% 40% / 0.6)" & @CRLF & _
"hsla(340 90% 80% / 0.1)" & @CRLF & _
"hsl(240, 100%, 50%)" & @CRLF & _
"hsl(240, 100%, 50%, 0.1)" & @CRLF & _
"" & @CRLF & _
"hsl(240,100%,50%,0.1)" & @CRLF & _
"hsl(180deg, 100%, 50%, 0.1)" & @CRLF & _
"hsl(3.14rad, 100%, 50%, 0.1)" & @CRLF & _
"hsl(200grad, 100%, 50%, 0.1)" & @CRLF & _
"hsl(0.5turn, 100%, 50%, 0.1)" & @CRLF & _
"" & @CRLF & _
"hsl(240.5, 99.99%, 49.999%, 0.9999)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"hsl(240.0, 100.00%, 50.000%, 1.0000)" & @CRLF & _
"" & @CRLF & _
"hsl(240 100% 50%)" & @CRLF & _
"hsl(240 100% 50% / 0.1)" & @CRLF & _
"hsla(240, 100%, 50%)" & @CRLF & _
"hsla(240, 100%, 50%, 0.1)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")