import Foundation
let pattern = #"^hsla?\(\s*(?<h>[-+]?\d{1,3}(?:\.\d+)?)(deg|grad|rad|turn)?\s*(?:,\s*|\s+)\s*(?<s>[-+]?\d{1,3}(?:\.\d+)?)%\s*(?:,\s*|\s+)\s*(?<l>[-+]?\d{1,3}(?:\.\d+)?)%\s*(?:,\s*|\s+)?(?:\s*\/?\s*(?<alpha>[-+]?[\d.]+%?)\s*)?\)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
hsl(.9, .99%, .999%, .9999)
hsl(0240, 0100%, 0050%, 01)
hsl(2400, 1000%, 1000%, 10)
hsl(-2400.01deg, -1000.5%, -1000.05%, -100)
hsl(2.40e+2, 1.00e+2%, 5.00e+1%, 1E-3)
hsl(-240, -100%, -50%, -0.1)
hsl(+240, +100%, +50%, +0.1)
HSL(240Deg, 100%, 50%)
hsl(240, 100%, 50%, 10%)
hsl(150deg 30% 60%)
hsl(0.3turn 60% 45% .7)
hsl(0.3grad 60% 45% / .7)
hsl(0.3rad 60% 45% / .7)
hsl(12 60% 45% / .7)
hsl(120, 100%, 50%)
hsl(0, 0%, 0%)
hsl(60, 50%, 75%)
hsl(270, 80%, 60%)
hsl(200, 20%, 40%)
hsl(340, 90%, 80%)
hsla(120, 100%, 50%, 0.5)
hsla(0, 0%, 0%, 0.2)
hsla(60, 50%, 75%, 0.8)
hsla(270, 80%, 60%, 0.4)
hsla(200, 20%, 40%, 0.6)
hsla(340, 90%, 80%, 0.1)
hsl(120 100% 50%)
hsl(0 0% 0%)
hsl(60 50% 75%)
hsl(270 80% 60%)
hsl(200 20% 40%)
hsl(340 90% 80%)
hsla(120 100% 50% / 0.5)
hsla(0 0% 0% / 0.2)
hsla(60 50% 75% / 0.8)
hsla(270 80% 60% / 0.4)
hsla(200 20% 40% / 0.6)
hsla(340 90% 80% / 0.1)
hsl(240, 100%, 50%)
hsl(240, 100%, 50%, 0.1)
hsl(240,100%,50%,0.1)
hsl(180deg, 100%, 50%, 0.1)
hsl(3.14rad, 100%, 50%, 0.1)
hsl(200grad, 100%, 50%, 0.1)
hsl(0.5turn, 100%, 50%, 0.1)
hsl(240.5, 99.99%, 49.999%, 0.9999)
hsl(240.0, 100.00%, 50.000%, 1.0000)
hsl(240 100% 50%)
hsl(240 100% 50% / 0.1)
hsla(240, 100%, 50%)
hsla(240, 100%, 50%, 0.1)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)