using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(FST|(?<!SCO)RAP((?!\s?POS)|(?=AT+N)))";
string input = @"RAPPOS
RAP POS
SCORAP
FSTLA1
RAPATN
RAP ATTN
RAP001
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}