import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(FST|(?<!SCO)RAP((?!\\s?POS)|(?=AT+N)))";
final String string = "RAPPOS\n"
+ "RAP POS\n"
+ "SCORAP\n"
+ "FSTLA1\n"
+ "RAPATN\n"
+ "RAP ATTN\n"
+ "RAP001\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}