re = /(FST|(?<!SCO)RAP((?!\s?POS)|(?=AT+N)))/m
str = 'RAPPOS
RAP POS
SCORAP
FSTLA1
RAPATN
RAP ATTN
RAP001
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end