using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"POST OFFICE(?!( (STREET|ST|ROAD|RD|WAY|WY|LANE|LN|BOULEVARD|BLVD|TERRACE|TER)))";
string input = @"1234 POST OFFICE BLVD";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}