$re = '/POST OFFICE(?!( (STREET|ST|ROAD|RD|WAY|WY|LANE|LN|BOULEVARD|BLVD|TERRACE|TER)))/';
$str = '1234 POST OFFICE BLVD';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);