import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "POST OFFICE(?!( (STREET|ST|ROAD|RD|WAY|WY|LANE|LN|BOULEVARD|BLVD|TERRACE|TER)))";
final String string = "1234 POST OFFICE BLVD";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}