using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\+(374)\s{1}[(](98|97|91|93|94|95|96|99|33|41|44|43|77|55)[)]\s{1}\d{2}[-]{1}\d{2}[-]{1}\d{2}$";
string input = @"+374 (98) 11-11-11";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}