const regex = /\+(374)\s{1}[(](98|97|91|93|94|95|96|99|33|41|44|43|77|55)[)]\s{1}\d{2}[-]{1}\d{2}[-]{1}\d{2}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\+(374)\\s{1}[(](98|97|91|93|94|95|96|99|33|41|44|43|77|55)[)]\\s{1}\\d{2}[-]{1}\\d{2}[-]{1}\\d{2}$', '')
const str = `+374 (98) 11-11-11`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}