import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\+(374)\\s{1}[(](98|97|91|93|94|95|96|99|33|41|44|43|77|55)[)]\\s{1}\\d{2}[-]{1}\\d{2}[-]{1}\\d{2}$";
final String string = "+374 (98) 11-11-11";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}