use strict;
my $str = 'Hello wo-r+ld%';
my $regex = qr%\QWO-R+LD%\E%ip;
my $subst = 'Earth';
my $result = $str =~ s%$regex%$subst%r;
print "The result of the substitution is' $result\n";