import Foundation
let pattern = #"\QWO-R+LD%\E"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"Hello wo-r+ld%"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Earth"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}