$re = '%\QWO-R+LD%\E%i';
$str = 'Hello wo-r+ld%';
$subst = "Earth";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;