use strict;
my $str = 'table 9070 "Accounting Services Cue"
{
Caption = \'Accounting Services Cue\';
fields
{
field(1; "Primary Key"; Code[10])
{
Caption = \'Primary Key\';
}
field(2; "Requests to Approve"; Integer)
{
CalcFormula = Count ("Approval Entry" WHERE (Status = CONST (Open),
"Approver ID" = CONST (\'USERID\')));
Caption = \'Requests to Approve\';
Editable = false;
FieldClass = FlowField;
}
field(4; "Ongoing Sales Invoices"; Integer)
{
CalcFormula = Count ("Sales Header" WHERE ("Document Type" = FILTER (Invoice)));
Caption = \'Ongoing Sales Invoices\';
FieldClass = FlowField;
}
field(5; "My Incoming Documents"; Integer)
{
CalcFormula = Count ("Incoming Document");
Caption = \'My Incoming Documents\';
FieldClass = FlowField;
}
field(20; "User ID Filter"; Code[50])
{
Caption = \'User ID Filter\';
FieldClass = FlowFilter;
}
}
keys
{
key(Key1; "Primary Key")
{
Clustered = true;
}
}
fieldgroups
{
}
}
';
my $regex = qr/\bfield\b\(.*\)\s*\n*\{[^\}]*\s+FieldClass = FlowField;[^\}]*\}
/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}