import Foundation
let pattern = #"""
\bfield\b\(.*\)\s*\n*\{[^\}]*\s+FieldClass = FlowField;[^\}]*\}
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
table 9070 "Accounting Services Cue"
{
Caption = 'Accounting Services Cue';
fields
{
field(1; "Primary Key"; Code[10])
{
Caption = 'Primary Key';
}
field(2; "Requests to Approve"; Integer)
{
CalcFormula = Count ("Approval Entry" WHERE (Status = CONST (Open),
"Approver ID" = CONST ('USERID')));
Caption = 'Requests to Approve';
Editable = false;
FieldClass = FlowField;
}
field(4; "Ongoing Sales Invoices"; Integer)
{
CalcFormula = Count ("Sales Header" WHERE ("Document Type" = FILTER (Invoice)));
Caption = 'Ongoing Sales Invoices';
FieldClass = FlowField;
}
field(5; "My Incoming Documents"; Integer)
{
CalcFormula = Count ("Incoming Document");
Caption = 'My Incoming Documents';
FieldClass = FlowField;
}
field(20; "User ID Filter"; Code[50])
{
Caption = 'User ID Filter';
FieldClass = FlowFilter;
}
}
keys
{
key(Key1; "Primary Key")
{
Clustered = true;
}
}
fieldgroups
{
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)