# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"\bfield\b\(.*\)\s*\n*\{[^\}]*\s+FieldClass = FlowField;[^\}]*\}\n")
test_str = ("table 9070 \"Accounting Services Cue\"\n"
"{\n"
" Caption = 'Accounting Services Cue';\n\n"
" fields\n"
" {\n"
" field(1; \"Primary Key\"; Code[10])\n"
" {\n"
" Caption = 'Primary Key';\n"
" }\n"
" field(2; \"Requests to Approve\"; Integer)\n"
" {\n"
" CalcFormula = Count (\"Approval Entry\" WHERE (Status = CONST (Open),\n"
" \"Approver ID\" = CONST ('USERID')));\n"
" Caption = 'Requests to Approve';\n"
" Editable = false;\n"
" FieldClass = FlowField;\n"
" }\n"
" field(4; \"Ongoing Sales Invoices\"; Integer)\n"
" {\n"
" CalcFormula = Count (\"Sales Header\" WHERE (\"Document Type\" = FILTER (Invoice)));\n"
" Caption = 'Ongoing Sales Invoices';\n"
" FieldClass = FlowField;\n"
" }\n"
" field(5; \"My Incoming Documents\"; Integer)\n"
" {\n"
" CalcFormula = Count (\"Incoming Document\");\n"
" Caption = 'My Incoming Documents';\n"
" FieldClass = FlowField;\n"
" }\n"
" field(20; \"User ID Filter\"; Code[50])\n"
" {\n"
" Caption = 'User ID Filter';\n"
" FieldClass = FlowFilter;\n"
" }\n"
" }\n\n"
" keys\n"
" {\n"
" key(Key1; \"Primary Key\")\n"
" {\n"
" Clustered = true;\n"
" }\n"
" }\n\n"
" fieldgroups\n"
" {\n"
" }\n"
"}\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.