package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)<*img.*\/>(.*)`)
var str = `<img src='img1.png' width='100' height='200'/><h1>Title 1</h1>
<img src='img2.png' width='100' height='200'/><h1>Title 2</h1>
<img src='img4.png' width='100' height='200'/><h1>Title 3</h1>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}