re = /<*img.*\/>(.*)/im
str = '<img src=\'img1.png\' width=\'100\' height=\'200\'/><h1>Title 1</h1>
<img src=\'img2.png\' width=\'100\' height=\'200\'/><h1>Title 2</h1>
<img src=\'img4.png\' width=\'100\' height=\'200\'/><h1>Title 3</h1>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end