import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([1-9]|0[1-9]|1[012])([-\\/.])([1-9]|0[1-9]|[12][0-9]|3[01])\\2(\\d{4})$|^(\\d{4})([-\\/.])([1-9]|0[1-9]|[12][0-9]|3[01])\\6([1-9]|0[1-9]|[12][0-9]|3[01])$";
final String string = "14/11/2015";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}