re = /^([1-9]|0[1-9]|1[012])([-\/.])([1-9]|0[1-9]|[12][0-9]|3[01])\2(\d{4})$|^(\d{4})([-\/.])([1-9]|0[1-9]|[12][0-9]|3[01])\6([1-9]|0[1-9]|[12][0-9]|3[01])$/
str = '14/11/2015'
# Print the match result
str.match(re) do |match|
puts match.to_s
end