import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "^Soldto:(?:.*\\R){2}\\K((?:(?!\\s{2}).)+)\\K\\s*\\K((?:(?!\\s{2}).)+)";
        final String string = "Soldto:                                 Shipto:                                 Billto:                                 \n"
	 + "00011222                                00017872                                10221060                                \n"
	 + "COSTCO CO INC. - GLOBAL EDI             COSTCO LANGLEY DEPOT                    COSTCO CO/LANGLEY                       \n\n\n";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
        final Matcher matcher = pattern.matcher(string);
        
        if (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}