$re = '/^Soldto:(?:.*\R){2}\K((?:(?!\s{2}).)+)\K\s*\K((?:(?!\s{2}).)+)/m';
$str = 'Soldto:                                 Shipto:                                 Billto:                                 
00011222                                00017872                                10221060                                
COSTCO CO INC. - GLOBAL EDI             COSTCO LANGLEY DEPOT                    COSTCO CO/LANGLEY                       
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);