use strict;
my $str = 'ff:ff:ff:ff:ff:ff <-> 00:1e:68:51:4f:a9 1 42 0 0 1 42 288.470566000 0.0000';
my $regex = qr/^([0-9A-F]{2}[:]){5}([0-9A-F]{2})$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}