import Foundation
let pattern = #"^([0-9A-F]{2}[:]){5}([0-9A-F]{2})$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"ff:ff:ff:ff:ff:ff <-> 00:1e:68:51:4f:a9 1 42 0 0 1 42 288.470566000 0.0000"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}