// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^([0-9A-F]{2}[:]){5}([0-9A-F]{2})$").unwrap();
let string = "ff:ff:ff:ff:ff:ff <-> 00:1e:68:51:4f:a9 1 42 0 0 1 42 288.470566000 0.0000";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}